Не запускается apache 2.4, в логах никакой информации

В продолжение моей заметки по обновлению apache 2.2 до 2.4 на RedHat 7.

После того, как конфиг был приведен к соответствию версии 2.4, апач не запускался, в логах было следующее:

[Wed Mar 27 12:05:37.548672 2019] [core:warn] [pid 11413] AH00098: pid file /etc/httpd/run/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed Mar 27 12:05:37.559141 2019] [mpm_prefork:notice] [pid 11413] AH00163: Apache/2.4.6 (Red Hat Enterprise Linux) PHP/5.4.16 configured -- resuming normal operations
[Wed Mar 27 12:05:37.559159 2019] [mpm_prefork:info] [pid 11413] AH00164: Server built: Jun 22 2018 01:19:25
[Wed Mar 27 12:05:37.559169 2019] [core:notice] [pid 11413] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
[Wed Mar 27 12:05:37.559178 2019] [mpm_prefork:debug] [pid 11413] prefork.c(1005): AH00165: Accept mutex: sysvsem (default: sysvsem)
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 10.222.128.6. Set the 'ServerName' directive globally to suppress this message

Конфигурация верна:

httpd -t
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 10.222.128.6. Set the 'ServerName' directive globally to suppress this message
Syntax OK

Но при запуске через systemd была какая-то задержка в 3 минуты, а потом процессы завершались. При этом параллельно было видно в ps aux, что процессы httpd появлялись, а потом убивались по таймауту.

Проблема оказалась в отсутствии модуля:

LoadModule systemd_module modules/mod_systemd.so

Также полезно смотреть, что прописано в systemd для юнита httpd и с какими параметрами он стартует.

Ваш комментарий будет первым

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *